One week at 100Mhz: Scary power failures

The one sad part about working with this machine is that I have discovered one or two mechanical flaws that are worrisome. And this time it’s not just the lack of USB ports.

I mentioned there is one detached key cap — something that could probably be fixed very quickly with a drop of cyanoacrilate — and that there is an occasional line of blue pixels running down the screen. But those are both overlookable … if that’s a word … since neither one really prevents me from using it.

On the other hand, this box has a sketchy power switch. If you remember old machines like this, some of them had two “power buttons” — one a simple power activator, like a push button on an elevator, and another one which was actually a switch that physically cut power to the system. Some old desktops put that switch at the back, and it was usually a rocker switch of some kind.

This has a similar arrangement, with a plastic slider as the “rocker” switch on the back left, and a sort of “restart” kind of button on the front. If I power down the machine and the AC is still attached, I can turn on the system by pressing that activation button. Or I can completely sever the power by switching the plastic switch at the back.

The fault lies somewhere in that rear power switch, which is probably worn with age. Occasionally it doesn’t slide fully to the “on” position, and the current will snap in and out at a frightening rate. It’s like an electric pulse popping through the entire system every half-second. The screen throbs white, the drives cluck and click as their power is applied and then cut immediately. It’s exceptionally scary. :shock:

Generally I try to avoid messing with that switch, leaving it in a fully “on” position and using a power strip “surge protector” to cut power when I leave for the day, or when I want to be sure the AC adapter isn’t pulling a current. It seems to be an okay solution.

The same switch might be to blame for another strange phenomenon. Right now the weather is turning from cold to cool, and the humidity is up as the spring rains set in. In the morning, when the machine has been powered down for the night, it’s starting at a very low temperature (I do not have “central heat,” as is common in some other countries) and as it heats up, some of the components flex in their braces.

So usually after about 20 minutes of use, I’ll hear the distinct “pop” of a component shifting as it expands, and the power cycles on the machine. It usually happens after I place my hands on the plamrests, changing the pressure on the frame and allowing the components to slide slightly. And I have a feeling the guilty party is that same switch again, shifting and losing its connection when the temperature reaches a certain point and its board relaxes.

As it gets warmer it shouldn’t be as much of a problem. But it does mean in the here and now, I occasionally walk away from the machine and come back to find it rebooting and doing a file system check. :evil:

Neither of these things came into play in the past because the system was never really on for very long. I would boot a kernel, try a configuration, test a piece of software, then shut down. And rarely did I rely on it for so much typing and “hands-on” use.

But neither of these things bodes well for the machine beyond my personal use. It will take a geek of considerable patience to put up with a sketchy power switch, and it will take a geek of even more considerable expertise to consider repairing that. I don’t count myself among the electrically-minded technophiles; if a component stops working, that’s where I draw the line for usability.

Oh, and I am also a kludge with a soldering iron. :roll:

But these are the things you discover when you take on a charity case and put it back to work again. Every machine has its quirks, I just wish this one’s weren’t quite so dramatic. :shock:

About these ads

8 Responses to “One week at 100Mhz: Scary power failures”


  1. 1 Onyros 2009/02/24 at 11:14 AM

    Hehehe, you’ve fallen in love with long text! The same thing happened to my e-mails when I started using a console MUA (that’s how fine mutt people like to call their app).

    That’s why I can never, ever be a journalist again, even though that’s what I was trained to be: I write way too much. Love the long text! Long live the long text!

    I hope your 100MHz warrior survives the heat, I’m really enjoying the experiment.

  2. 2 karthik 2009/02/28 at 2:25 PM

    I had a 350 MHz Pentium II lying in the attic for several years. Trying to resurrect it last year, I wiped the dust off the case, plugged it in and pressed the mechanical power switch.

    The switch stuck, causing the scary pulsing you mentioned here. The power supply unit sparked, and the fuse for the electrical mains melted. Turns out the power supply unit blew, cracking the RAM chips in the process. Apparently disuse had caused the insides of the plastic switch to harden and collect grime.

    These mechanical “hard” switches scare me.


  1. 1 Role reversal « Motho ke motho ka botho Trackback on 2009/03/27 at 8:39 AM
  2. 2 A puzzle that doesn’t need solved « Motho ke motho ka botho Trackback on 2009/04/14 at 8:33 AM
  3. 3 An apology, and an update « Motho ke motho ka botho Trackback on 2009/05/17 at 9:01 PM
  4. 4 More observations on the effects of environment on antique hardware « Motho ke motho ka botho Trackback on 2009/05/26 at 10:14 PM
  5. 5 Putting the Pentium back to work « Motho ke motho ka botho Trackback on 2009/08/03 at 9:37 AM
  6. 6 Eclipsed, obsoleted, retired « Motho ke motho ka botho Trackback on 2009/08/27 at 10:17 PM

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s




Welcome!



Visit the Wiki!

Some recent desktops


May 6, 2011
Musca 0.9.24 on Crux Linux
150Mhz Pentium 96Mb 8Gb CF
 


May 14, 2011
IceWM 1.2.37 and Arch Linux
L2300 core duo 3Gb 320Gb

Some recent games


Apr. 21, 2011
Oolite on Xubuntu 11.04
L2300 core duo 3Gb 320Gb

Enter your email address to subscribe to this blog and receive notifications of new posts.

Join 405 other followers

License

This work is licensed under the GNU Free Documentation License. Please see the About page for details.

Blog Stats

  • 3,963,645 hits

Archives


Follow

Get every new post delivered to your Inbox.

Join 405 other followers

%d bloggers like this: