Correcting a long-running error

I started this blog because I wanted to keep track of notes and configuration settings in a way that was more persistent and trustworthy than a piece of paper or a file somewhere on a local drive. A good example is the settings for a Japanese keyboard under X.

Unfortunately, I was always about 10 percent wrong on those settings, and I finally, this morning, came up with the options that get all the keys working properly. It might sound odd that I’ve been using Japanese key configurations for a year and a half and sometimes they’re not quite right, but the odd keys that don’t come into play … never really come into play.

But this is 100 percent correct, as far as I can tell, and so I put it here to preserve it into the future.

Under Section "Keyboard",

Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "jp106"
Option "XkbLayout" "jp"
Option "XkbVariant" ""

I think that's correct. Or at least now those one or two odd keys (like the right curly bracket) that weren't quite right ... are.

P.S.: Sorry if this is boring. I'll try to have something more spicy to tell in a day or so. :D

About these ads

5 thoughts on “Correcting a long-running error

  1. johnraff

    Might seem boring, but an uncooperative keyboard can be infuriating. >_<
    Glad you got it fixed. Did you find some wonderful source of advice on Japanese keyboard-tweaking?

    I’m on Gutsy, so things might be different for you, but on my xorg.conf there’s no Section “Keyboard”, like so:
    —–(from my xorg.conf)—–
    Section “InputDevice”
    Identifier “Generic Keyboard”
    Driver “kbd”
    Option “CoreKeyboard”
    Option “XkbRules” “xorg”
    Option “XkbModel” “jp106″
    Option “XkbLayout” “jp”
    Option “XkbVariant” “jp106″
    Option “XkbOptions” “grp:caps_toggle,lv3:ralt_switch,grp_led:scroll”
    EndSection
    ——————————
    Apart from the Section name, differences from your version are that I’ve got “jp106″ for “XkbVariant”, and that list of “XkbOptions”. To be honest I can’t remember how I got here, but it seems to be working OK, except that occasionally I hit the wrong key combination, get switched to kana input, “Caps Lock” and “Scroll Lock” lights come on, and I have to stop X to get back to normal.

    Reply
    1. K.Mandla Post author

      No, no secret source to reveal. I pieced that together from several forum posts, blog posts and an offhand instruction page or two. I used to set XkbVariant as jp106, and it might be that it’s a working option. I’ve also seen the layout as “jp,jp”. Who knows? Maybe somewhere on the Intarnets there’s a manual I should be RTFMing. :mrgreen:

      Reply
  2. johnraff

    Actually there is man xorg.conf !
    I’ve just found this and it says, along with many, many other things, the Section “Keyboard” is now obsolete…
    No concrete advice about Japanese keyboards though so we’re still stuck with voodoo.

    My Intrepid laptop’s xorg.conf hasn’t got anything about the (also Japanese) keyboard at all, but the latest version of X seems to have set it up OK all by itself during the install process. (It needed help with the display though.)

    Reply
    1. K.Mandla Post author

      I think the last time I used full-blown Ubuntu everything was set up correctly. My problems arrive when I install a command-line system, add X on top of that, and then find that it doesn’t know my keyboard from any other, or it sets the display options to something impossible for the hardware.

      To be honest, I had enough trouble with X since 7.4 came out that I’m just in the habit of hotwiring it without checking to see if it can do its job correctly. It’s possible that it can set up a keyboard without my prodding, and I just haven’t given it the chance. :|

      Reply
  3. johnraff

    The Intrepid laptop was indeed a basic CLI install with X added after. (very low-spec machine: 260MHz, 192MB)
    It failed to pick the right screen resolution, but keyboard setup went OK.

    Still, X’s new habit of doing everything behind closed doors is annoying.

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s