Dark days

It figures that the day after a week-long winter holiday, I end up with mysterious network failures on my Thinkpad. It’s running Arch right now, and about two minutes after the first startup, the wireless network dropped, and there’s no sign of the outside world.

I have two other machines that run wireless and I’m sure it’s not the network that’s at fault. That is the only one running Arch though, and the fact that it is failing is all the more disappointing. In general, that’s the one I use to manage my daily tasks, manage my e-mail, hold my music collection, watch movies, track my desktop wiki … and yes, it’s only a 550Mhz Celeron.

My fear is that it might be something hardware-related. I didn’t update any core software in the past few days. Looking at /var/log/pacman.log I can see that I synced with the repositories yesterday, but didn’t upgrade. Technically, nothing has changed.

But I’ve tried two different PCMCIA wireless cards — a Buffalo WLI-PCM-L11 that uses the prism module, and a Linksys WPC11 v3 that uses orinoco-cs — and both of them behave erratically.

The Linksys is worse, but that’s the one that was working fine up until this morning. When that one is inserted, I get wacky keyboard behavior like sticking keypresses, one- and two-second-long lags on typing. dmesg is littered with “CMDMODE_ACCESS failed” messages. It’s almost like working with Windows.

I booted to the 2008-06 core CD and tried there, and things were better, but not perfect. No keyboard misbehavior and the Buffalo card would insert and work properly, but the Linksys card is still tetchy. Neither one will associate with my network. I don’t manage my modules or rearrange any boot scripts, mostly because I want Arch to do it all by itself on this machine. So I am fairly certain that my mismanagement hasn’t fouled this up.

The strange thing is (and perhaps this is just my memory that’s failing) I know that this has happened to me in the past — both times running Arch on a wireless machine. I’ll have to scrape this site and see if I can find the reason, but I could swear that this machine and my OLPC were both knocked offline about six months ago, and I never resolved it.

But on the whole this is rather problematic. If it were a software issue, I’d think I’d be able to access the network from the live CD. If it were a card problem, I’d think one of them would work. But what’s scaring me now is the thought that the PCMCIA socket hardware in this machine, which I love dearly, might be at fault. :(

Edit, 2009-01-07: Well, now it appears to be okay. Whatever difficulty I was having has disappeared, and I haven’t the slightest clue why. Maybe something was interfering with the system. Like gremlins. I’m keeping an eye on this one though. I haven’t quit chasing it yet.

About these ads

3 Responses to “Dark days”


  1. 1 muaythaimaster74 2009/01/05 at 9:46 AM

    I had wireless wierdness in arch as well when I was using the stock dhcpcd. Installing dhclient and adding that to my daemons array in rc.conf worked much better IMHO.

  2. 2 K.Mandla 2009/01/05 at 10:06 AM

    Thanks, I’ll give that a try too. I saw on the forums where some people with seemingly similar problems had better luck with wicd. I’ll give it more attention later today. …

  3. 3 muaythaimaster74 2009/01/11 at 4:09 AM

    It’s weird that it suddenly started working again. Did you update dhcp recently? I was also thinking perhaps that your resolv.conf wasn’t being populated correctly.

    You could check in /var/log/everything.log for a listing of what’s going on with your system.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s




Welcome!



Visit the Wiki!

Some recent desktops


May 6, 2011
Musca 0.9.24 on Crux Linux
150Mhz Pentium 96Mb 8Gb CF
 


May 14, 2011
IceWM 1.2.37 and Arch Linux
L2300 core duo 3Gb 320Gb

Some recent games


Apr. 21, 2011
Oolite on Xubuntu 11.04
L2300 core duo 3Gb 320Gb

Enter your email address to subscribe to this blog and receive notifications of new posts.

Join 405 other followers

License

This work is licensed under the GNU Free Documentation License. Please see the About page for details.

Blog Stats

  • 3,963,198 hits

Archives


Follow

Get every new post delivered to your Inbox.

Join 405 other followers

%d bloggers like this: