By the way … Crux 2.5 on a K6-2+, 256Mb

Edit: Unfortunately, these images are gone, because of image hosting problems in late 2009. My apologies.

It’s hard to believe that it’s been almost a year and a half since I first brought home a smashed, cracked, beaten, faded, abused, misused, unused laptop and started using it for a guinea pig. I can’t even count how many different distros I tried on it, giving each one a chance to perform on a machine I consider mid- to low-grade hardware.

The best system to date, however, was still Crux 2.4 in the i586 flavor, which astounded me with a 25-second boot to a graphical desktop — something no other distro ever came close to. I was so excited about that, it pushed me over the edge and I now use Crux on a daily basis, on at least two other machines.

Recently I’ve managed to whack it down even further, for a boot time of about 20 seconds plus wireless access through a Hermes-based PCMCIA card, native 1024x768x16 graphics, Firefox 3, Flash 10, stereo audio, USB 1.1 and CDROM access. Most of the speed increase is, no doubt, due to the fact that I’m using a 20Gb 5400rpm drive in the place of the old 5Gb 4200rpm hard drive I was using before.

But this is still a complete and fully functional system usable for watching the web, streaming audio, typing e-mails … just about anything, with the only exception being proper multicharacter support (in other words, Japanese text) — the keyboard is easily configured, but I never did get SCIM to display fonts properly, as it does in Arch.

For me, that’s only a small inconvenience, and doesn’t discount the fun of it all.

Bumping up 2.4/i586 to 2.5 is an easy thing to do: Simply edit the rsync files in /etc/ports and change the reference to 2.4 to 2.5. I started with a full graphical desktop from the 2.4 i586 ISO, then did a systemwide upgrade once the network was up and working. That way I could troubleshoot any problems I was experiencing without worrying if my packages miscompiled.

A small graphical glitch: The newer version of xserver doesn’t seem to like the 1.4.1 or the 1.5 versions of the siliconmotion driver. For whatever reason (I’m not exactly obsessed with tracking it down), the driver won’t compile if the newest version is in place. So overall it’s easy to fix; I just leave the old version of xserver in place, and use whichever driver version I prefer, the precompiled or newest.

Configuring X takes a little more effort with this, because the monitor doesn’t seem to autodetect, and the keyboard needs a few more tweaks. Usually I let X try its best to get it right, but sometimes it doesn’t do a very good job.

Lately I’ve just been starting with this, from the root prompt.

X -configure

Then editing the resulting xorg.conf.new file, and moving it to /etc/X11 when I'm done. Otherwise I find that X's startup tries to redefine it all over again, usually getting it wrong. Here are the changes I make for the 2Mb Silicon Motion SM712 LynxEM+ card and Japanese keyboard.

Option "AllowEmptyInput" "false"

This one goes in the ServerLayout section, since I don't use HAL. Under the keyboard section. ...

Option "XkbLayout" "jp,jp"
Option "XkbRules" "xorg"
Option "XkbVariant" "106"

Those settings make my keyboard trigger the letters that are the same as what's painted on top of them. That's always nice to have. :mrgreen:

These are what I add to the monitor configuration section, so the full screen is used. On its own X can't seem to trust the monitor enough to do the full 1024x768, and I already have two screens at 800x600. One more is not appealing. ;)

DisplaySize 346 260
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 70.0

Those are calcuated by the information from xdpi, if I remember right. I think they're probably safe to use if you have a 1024x768 monitor; if not, you'll know. And of course, since the screen can't do 24-bit color, I make sure there's no confusion and tell it to go straight to 16-bit.

DefaultDepth 16

Easier done than said. At the kernel level, I've taken to disabling almost everything, with certain exceptions. I need the Hermes chipset plus the PC card option, as well as the yenta driver, wireless protocols and the pcmciautils package to make a Buffalo WLI-PCM-L11 card go zoom. Network speeds are about what I can expect from any 11b card -- no more, but no less either.

Audio is an ESS Technology ES1969 Solo-1 Audiodrive, which is driven at the kernel level in the Alsa subsection, and works fine with everything I throw at it. I don't make many demands on audio, mostly because laptop speakers usually suck -- or at least speakers on 10-year-old laptops suck. I have heard some modern laptops that sounded great.

For a hard drive partition, I split the 20Gb drive into 64M/128M/4G/~, mostly as a matter of habit. More and more though, I'm beginning to think those numbers aren't really necessary for me personally. I very, very rarely bother to preserve a home partition between installations. I might as well lump everything together and save myself the effort.

And yes, I still use only ext2 with everything. No matter what the filesystem doomsayers preach.

Now I know most of you probably chuckled when I mentioned Flash 10 on a K6-2+. And I'll admit that the performance under Firefox 3 is a bit ... sub-par. But it works, and I can prove it.

Okay, yeah, it's a bit lame to post a video on YouTube of a video on YouTube. But judging by the ruckus that explodes in the Ubuntu Forums every time Flash stops working, the only reason to have Flash in Linux is to waste time watching videos of snails race. Hey, if that's your thing, that's cool with me. On the other hand, that snail race looks just as weak on the K6-2 as it does at 1Ghz, and probably does on whatever you're using. But there's naught so queer as folk, I guess.

Anyway, Flash isn't so much unusable as just unbearable, depending on your definitions. It works, yes. It works well. ... :|

Aside from that, I keep the choice of software intentionally narrow -- emelFM2, ObMenu, Leafpad, gcolor2, Mirage and some others that I regularly install Just for kicks, I installed xcompmgr on it, and yes, that works too. Not fantastic, but again, functional.

So overall, this is an even better computer than I knew it could be, way back when we first met. Granted, it will probably never run Compiz, but it's fast, it's functional, it's flexible, and if it wasn't for a noisy fan and a tetchy keyboard, it might even be something worth using on a daily basis. :)

About these ads

11 thoughts on “By the way … Crux 2.5 on a K6-2+, 256Mb

  1. Timóteo

    Wow, just the fact that you are running firefox3 under it is already impressive, with flash and xcomp then.

    That’s incredible.

    Reply
  2. K.Mandla Post author

    That’s true. :) I fell into that habit just because all-caps seems like shouting. A holdover from the forums, I guess.

    Reply
  3. manoj

    Updating a program is usually a good idea,but in some cases its not good. That is what we’re here for! There have been several instances where a new release of a program is not always good.reason is several factors.

    visit may be usefull for all

    http://old-versions.org/

    Reply
  4. Raden Mu'az

    I’m writing on Gentoo-powered VIA C3. Tried CRUX before but it really sucks (to me, of course). Xfce won’t compile.

    About compiling, VIA C3 compiles a kernel about 30-40 minutes , compared to Intel Core 2 Duo, which is only 3-4 minutes.

    Anyway, if you had too much time on your hand, try Gentoo. Lots of softwares in repo, guides, excellent wiki, and *more*.

    Reply
  5. K.Mandla Post author

    Hmm. That’s odd, I’ve used XFCE on Crux before, and had good luck with it, really. I’ll check MPlayer and Greasemonkey, and see how it goes.

    And I’ve actually tried Gentoo once or twice a very long time ago, but you’ve reminded me and I might try it one more time. I have a winter holiday coming up and should have time to tinker. Thanks!

    Reply
  6. Pingback: Banquo’s ghost: Lowarch 0.1.1 ISO and torrent « Motho ke motho ka botho

  7. Pingback: Happy anniversary to me « Motho ke motho ka botho

  8. Pingback: Nice browser, but that name … « Motho ke motho ka botho

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s