Fewer modules, but no speed gain

I tore out some more kernel modules from my MODULES=() line in /etc/rc.conf, but it didn’t do much to improve speed. My module list is now

MODULES=(snd-pcm snd snd-nm256 soundcore cdrom serio_raw psmouse evdev pcmcia pcmcia_core ieee80211_crypt hermes hostap hostap_cs orinoco orinoco_cs rtc rsrc_nonstatic yenta_socket i2c-piix4 i2c-core usbcore usb-storage usb-uhci)

Things like ata_piix and ata_generic didn’t do anything to prevent the machine from booting, as I had feared they might. I can still stream audio without snd-page-alloc and snd-timer. And since the MagicGraph 256AV is a PCI card, it didn’t seem to matter if I had agpgart or intel-agp inserted. I was right.

The only detriment I can see so far is that I seem to have lost my USB ports; or rather, the USB flash drive I have in there doesn’t seem to be responding to fdisk -l. I haven’t decided if it’s worth tracking down or not, since I hardly use it. I’ll think it over.

For now I’m still trying to dig up some dirt on getting X to start quicker. After that, about the only tweak I can think of to improve the speed would be a custom kernel. If I have to go to that route, I’ll save it for last.

Edit: Adding sd_mod solved my USB disk problem. :roll:

About these ads

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s