Xserver-xorg-core will break Xwindows

As mentioned on the forums, a recent version of xserver-xorg-core causes X to break on a lot of machines. I got dinged too, while I was trying to install the native ATI drivers on my brother’s zv6000. That was confusing as all heck. I thought I was really screwing things up, and in fact it was just an issue with an update.

Once I had that information, I made a little progress on the drivers. For some reason, his Radeon Xpress 200M just doesn’t care to do any 3D acceleration.

I got the wireless to work with bcm43xx-fwcutter, but it needs a little more tweaking. It doesn’t connect on startup, which I think is just a matter of editing the /etc/network/interface file. I did it for mom’s 600m, so it should work … sometime.

That video is a real bear, though. If I get it working, it will be a real coup. Otherwise … he’ll just have to get a new laptop.

(By the way, I fixed the xserver-xorg-core issue with sudo aptitude remove –purge xserver-xorg-core, and accepted the solution to downgrade. It works the same as most of the other fixes listed.)

About these ads

2 thoughts on “Xserver-xorg-core will break Xwindows

  1. Pingback: Two more to freedom « Motho ke motho ka botho

  2. Pingback: Let me tell you about the good old days. … « Motho ke motho ka botho

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s